Рассмотрим подключение внешних отчетов, обработок и печатных форм на примере конфигурации ЗУП 3.1.1.91.

Для подключения внешнего файла переходим в раздел Администрирование – Печатные формы, отчеты и обработки – Дополнительные отчеты и обработки (рис. 1, рис. 2):

Рис. 1. Администрирование – Печатные формы, отчеты и обработки

Рис. 2. Дополнительные отчеты и обработки

Нажимаем Создать (рис. 3):

Рис. 3. Добавление файла

Появляется сообщение Предупреждение безопасности, если файл точно нужный и безопасный, нажимаем Продолжить (рис. 4):

Рис. 4. Предупреждение безопасности

Появляется окно для выбора файла, выбираем нужный файл, в примере это будет внешний отчет пр_ОтчетПоКадровымПеремещениям, нажимаем Открыть (рис. 5):

Рис. 5. Выбор файла

После выбора файла заполняются поля формы дополнительного отчета (рис. 6):

Рис. 6. Поля формы внешнего дополнительного отчета

Т.к. Размещение <Не задано>, нужно определить, в каких разделах будет видна команда вызова отчета. Нажимаем ссылку <Не задано> (рис. 6) и указываем раздел Кадры, нажимаем ОК (рис. 7):

Рис. 7. Выбор раздела

Указываем пользователей, которым будет доступен отчет: переходим в табличную часть формы в поле Быстрый доступ (рис. 8):

Рис. 8. Настройка быстрого доступа

Выбираем пользователя, нажимаем >, выбранный пользователь окажется в разделе Пользователи, для которых видна команда и нажимаем ОК (рис. 9):

Рис. 9. Выбор пользователя

Теперь можно записать и закрыть форму внешнего отчета (рис. 10):

Рис. 10. Сохранение внешнего отчета

Переходим в раздел Кадры – Сервис – Дополнительные отчеты, в котором должна появиться команда вызова внешнего отчета (рис. 11):

Рис. 11. Кадры – Сервис – Дополнительные отчеты

Открывается форма Дополнительные отчеты, выбираем нужный отчет (название отчета задается при регистрации внешнего отчета, рис. 6 в табличной части формы колонка Наименование) и нажимаем Выполнить (рис. 12):

Рис. 12. Запуск отчета

Если в разделе Кадры отсутствует команда Сервис – Дополнительные отчеты, нужно ее вывести. Нажимаем значок Настройки (рис. 13):

Рис. 13. Настройка команд раздела

Выбираем пункт Настройка действий (рис. 14):

Рис. 14. Настройка действий

В открывшемся окне Настройка панели действий в разделе Доступные команды выбираем Сервис – Дополнительные отчеты, нажимаем Добавить (после этого команда появится в разделе Выбранные команды), нажимаем ОК (рис. 15):

Рис. 15. Добавление команды Дополнительные отчеты

После этого в разделе Кадры появится пункт Сервис – Дополнительные отчеты (рис. 16):

Рис. 16. Кадры – Сервис – Дополнительные отчеты

Добавление внешней обработки аналогично добавлению внешнего отчета, только искать нужную внешнюю обработку нужно в разделе Сервис – Дополнительные обработки (внешние отчеты можно найти в разделе Сервис – Дополнительные отчеты, рис. 11).

Добавление внешней печатной формы аналогично добавлению внешнего отчета. В поле Размещение (рис. 10) будет указан объект, к которому относится печатная форма. Нужно открыть этот объект и у него при нажатии на кнопку Печать появится пункт с наименованием добавленной внешней печатной формы (наименование задается при регистрации внешней печатной формы, рис. 6 в табличной части формы колонка Наименование).

Если при регистрации файла происходит ошибка:

Для того, чтобы при регистрации внешнего отчета/обработки верно заполнились все поля формы внешнего отчета/обработки и регистрация прошла успешно, нужно в модуле объекта прописать определенные процедуры. Пример модуля объекта для файла внешнего отчета:

Функция СведенияОВнешнейОбработке() Экспорт
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("");

    ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Отчет по кадровым перемещениям");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Информация", "Дополнительный отчет");
    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд, "Отчет по кадровым перемещениям", "_ОтчетПоКадровымПеремещениям", "ОткрытиеФормы", Истина);

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры